Any tips on the scroll bar. When I add enough rows that a scrollbar appears I get two issues:

  • The vertical scrollbar consumes part of the last cell. Seems to me the width of the table must be fixed and the scrollbar is forced to eat part of the last cell so it will fit. I am overriding the width via –smart-grid-default-width: 100%;, otherwise the grid seems to ignore the cell widths I set. Might just be how I have the HTML/CSS set on my end.
  • More importantly when I scroll up/down the grid seems to be having trouble moving to other rows. If I populate data for the first row, scrolling down always has me still seeing the first row at the top.
    • I opted to keep the scrolling at the default “physical”.
    • I opted to not make a custom dataSource as the tree will go ahead and make its own.
      • I use grid.addRow(…) to add an object that looks like this:
        • {
          ‘Option 1’: <value>,
          ‘Option 2’: <value>,

What might I be missing? Is having the tree create the data source not the way to go? Perhaps the custom cell templates are the problem.

Edit: I may see the problem now, it is the templates. Leaving the post here if you have any pointers. Performance seems slower then usual, but I suspect its the re-drawing of the cells. Redrawing seems to get called excessively. I can perhaps add logic to not do heavy lifting unless something actually changed. If I changed one cell of row 1 it seems to kick off a repaint of all cells in all rows.