Sorry I was forced to change the account because I don’t receive mails anymore on the other account.

Anyway I still find the problem.

I suspect the problem coud be my PC language setting which is Italian.

When I open the date picker I see all in english.

Is there any specific setting for the datekeeper related to language ?