Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #104209
    JC
    Participant

    I need to localize a Date Input to Spanish and also changing FirstDayOdWeek to 1 (Monday) on Angular.

    I’ve tried this but didn’t work:
                  {
                    dataField: ‘invoiceDate’,
                    controlType: ‘date’,
                    label: ‘Fecha’,
                    placeholder: ‘Elegir fecha’,
                    cssClass: ‘underlined’,
                    firstDayOfWeek: 1,
                    locale: ‘es’,
                    formatString: ‘d/M/yyyy’,
                    firstDay: 1
                  }

    also

                  {
                    dataField: ‘idCardDueDate’,
                    controlType: ‘date’,
                    label: ‘Fecha de expiración’,
                    placeholder: ‘Elija fecha’,
                    cssClass: ‘underlined’,
                    controlOptions: {
                      formatString: ‘d/M/yyyy’,
                      firstDayOfWeek: 1,
                      locale: ‘es’
                    }
                  }

    No error messages or warnings, just keep showing pop-up calendar starting on Sunday and labels in English.

    Please help

    • This topic was modified 1 year, 5 months ago by JC.
    #104213

    Hi,

    The options of the control should be passed in a controlOptions object,
    Please see this demo made for your purposes:

    https://codepen.io/svetoslavb04/pen/RwBgVQM

    The same template can be used in Angular.

    I hope this helps you

    Best Regards,
    Svetoslav Borislavov

    Smart UI Team
    https://www.htmlelements.com/

    #104214
    JC
    Participant

    Thanks a lot. It helped but the titles on tabs (Date and Time) when you click on calendar icon appears as ‘undefined’

    P.S.: I sent an email to support@ regarding other issues.. I’m waiting for your answer.

    • This reply was modified 1 year, 5 months ago by JC.
Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.