Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #104071

    Anyway we can get you all to fix the import issues with the Theme Builder. This is an important tool in order to use the UI lib. The details…

    Typically, we use the advanced, which I can assume most dev teams will be using. Not mater what I do, I can’t seem to import my theme and pick up from where I last left off. Seems to be no issues with using the default light but whenever I jump into a Dark theme, make some changes, then export meta data, I’m unable to successfully import that meta data and continue on from where I left. I can start in a light Advanced theme and successfully import a dark theme but it doesn’t work properly due to having a mix of light and dark inside the editor.

    Steps to reproduce…

    1. Browse to Advanced Theme Builder
    2. Chose a dark theme and make a least one change (like primary color)
    3. Export theme as meta data json file
    4. Refresh page (or open new session) for Advanced theme.
    5. Import saved theme (both methods below for light and dark)
    A. With default light theme, import meta data. Notice that meta data components seem to have dark theme elements but theme editor is still in light mode and does not display like it should as in dark mode.
    B. In default light theme, choose any of the dark themes. Then import meta data from saved dark theme. Notice is does nothing but add a new them to theme selector (which is NOT selected by default) and when choosing that custom theme, is not correct options.


    I take it back…light also does not work properly. I imported a newly saved custom theme (based from light Blue theme), then on a new tab, in advanced light theme builder page, imported the new theme. I updated most of the properties but was still missing pieces, like default button theme.


    Hi Robert,

    Thank you for the feedback. We will test the reported behaviors.

    Best regards,
    Peter Stoev

    Smart UI Team

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.