HTML Elements Forums Charts & Data Viz Chart & Gantt Chart Auto height not working?

Tagged: 

This topic contains 3 replies, has 3 voices, and was last updated by Avatar B. Markov 5 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #100691
    Avatar
    Aks26
    Participant

    As the title suggests, setting height: auto in the CSS file does not seem to be working. I tried with min-height and a few other awkward options as well. Is there a way to set the height for the Gantt Chart to be automatically fitted according to the number of stages.

    #100692
    Avatar
    admin
    Keymaster

    Hi Aks26,

    We have a demo about auto-height: https://www.htmlelements.com/demos/gantt/auto-height/. Do you use our latest version – Smart UI 7.4.0?

    Regards,
    Peter

    Smart UI Team
    https://www.htmlelements.com/

    #100716
    Avatar
    Aks26
    Participant

    Hi, replying after quite a while because I thought I had fixed it. But as I said, the auto-height function seems to be a bit buggy. Also, I am using the latest Smart UI version. What happens is sometimes the chart displays as I want it to, some other times it is collapsed and scrollbars show up.

    If anything, prolonged click on the reload button and selecting the ‘Empty cache and hard reload’ option fixes this consistently. So can you help me out? Even if the chart itself is buggy, can you perhaps give me a solution in angular regarding how I can bypass this? Basically, I want the whole thing to show up in full rather than with scrollbars….which seems to happen only if the cache is cleared. Thanks.

     

    #100717
    Avatar
    B. Markov
    Participant

    Hi Aks26,

    Please, provide an example which reproduces the behavior which you report. The problem could be in the Gantt, but also could be caused by something else. We cannot tell from the information, which we have.

    Regards,
    Peter

    Smart UI Team
    https://www.htmlelements.com/

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.