I’ve noticed a considerable variety in the approach to naming component properties and methods. This slows down the learning and adoption of your products.
For instance, I’ve noticed that in some components a “showXXXXXX” property or “hideXXXXX” property naming convention is used to designate properties that are related to showing or hiding various display elements of a component.
However, for the ‘Kanban’ component, it does not follow those conventions.
show/hide are used when there is required API for showing/hiding something. In Kanban, there is no feature which requires such API. When we add more features to it in the future which require such API, we will most probably add it.
Smart UI Team https://www.htmlelements.com/