This topic contains 4 replies, has 4 voices, and was last updated by Avatar Hristofor 5 months, 2 weeks ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #100329
    Avatar
    Anonymous

    Hi,

    Here are several issues I have noticed with <smart-gantt-chart>!

    Number 1 and 4 are major issues.

    1. https://codepen.io/cetinsert/pen/pozZoNj?editors=1011
      /source/smart.elements.js – does not define <smart-gantt-chart>!
      customElements.get(‘smart-window’); // defined
      customElements.get(‘smart-gantt-chart’); // undefinedthis renders all Gantt Demos Codepen links broken.

      See – https://codepen.io/cetinsert/pen/dybjyWK (had to explicitly add reference to /source/smart.ganttchart.js)

    2. Is there a way to hide the label task column but show other user defined ones?
    3. Is there a way to hide all task columns?
    4. g.updateTask(index, { label }); sets task.dateEnd, scrolls the view, might have other side effects – I would like to hide all task columns and display task dateStart, dateEnd on the timeline task items themselves but the side effects make it impossible

      https://codepen.io/cetinsert/pen/dybjyWK?editors=1010
      g.updateTask(0, { label: “2” }); // results in dateEnd set to year 2100
      g.updateTask(0, { …g.tasks[0], label: “2” }); // results in the same

    5. gantt.max = new Date(…) works but not <smart-gantt-chart max=’YYYY-MM-DD’> or g.max = ‘YYYY-MM-DD’
    6. CSS documentation mentions variables that are out of sync with the actual 4.4 implementation. Variable names differ, such as those for timeline task background colors.

    Thanks

     

    • This topic was modified 1 year, 10 months ago by Avatar .
    • This topic was modified 1 year, 10 months ago by Avatar .
    #100333
    Avatar
    Anonymous

    Hello,

    I wish everyone a great new week!

    Please review this topic.

    Thank you.

    #100336
    Avatar
    Anonymous

    Hi cetinsert,

    Thank you for the feedback ! The issues will be fixed in our next release. We constantly update the components and new CSS variables could be introduced while others might be renamed/removed. So we will update the documentation and try to keep it up to date. Regarding your 2nd and 3rd question the taskColumns can be removed by setting taskColumns = []. Also if you want to hide the task tree container just set `treeMin = ‘0px’ and ‘treeSize = ‘0px’. That will set the min and size of the TaskTree to 0.

    Best Regards,
    Christopher

    Smart HTML Elements Team
    https://www.htmlelements.com

    #101522
    Avatar
    Walter
    Participant

    Hi,

    I have a question on the duration of the project; if I set the durationUnit = ‘hour’ and view =’week’ (worked on example of https://www.htmlelements.com/demos/gantt/custom-popup-window/) and set nonworkingHours and nonworkingDays like this:

    gantt.nonworkingHours = [ 0, 1, 2, 3, 4, 5, 6, 7, 8, 13, 18, 19, 20, 21,22, 23 ];
    gantt.nonworkingDays = [ 0, 6 ];

    for use only 8 hours for day, the duration of task work correctly, but the duration of syncronized project is calculated with 24 hours and not 8. The properties nonworkingHours e nonworkingDays  doesn’t work for projects with syncronized=true? It’s possible to change?

    Thank you in advance.

    Walter

     

    #101523
    Avatar
    Hristofor
    Participant

    Hi Walter,

    Thank you for the report. Synchronized projects calculate their duration based on the working time of their tasks. However in the current version of the Smart.GanttChart this does not happen when loading a dataSource. Instead the validation occurs on other occasions, for example after a project’s task has been dragged or resized. This will be fixed in our next release. As a workaround I can suggest switching the GanttChart to ‘resource’ view and then back to ‘week’. Switching to ‘resource’ view will trigger the synchronized projects validation.

    Best Regards,
    Christopher

    Smart HTML Elements Team
    https://www.htmlelements.com

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.